0

It has recently pointed out to me that if we run our url on Google PageSpeed Insights our results for Mobile are '0' and our results for Desktop are between 20-29.

What is VERY strange however is that if I use Chrome Development Tools and run Audits (Lighthouse), we do actually get results if I run it through an Incognito Browser. I have seen the process fail in a standard windows, however re-running the process a few times will usually result in a success. Incognito seems to work straight away though.

In my attempt to fix this I removed 'Addthis' from our development copy (hoping it was somehow causing it) and did observe an increase in the browser development tools audits BUT PageSpeed Insights still reports '0' for mobile and 20-29 for desktop.

See Images below:

enter image description here

enter image description here

So removing 'Addthis' did not solve the issue. The fact I am getting conflicting results is a bit worrying, I am worried this could be affecting our rankings in Google.

Has anyone ever experienced this issue or have any idea what might be causing this?

For information purposes:

Our store runs with only a few extensions, one is a payment gateway for cards, the second is an improved search box, the third is an SEO extension, last one is a Google Recaptcha extension.

In regards to theme we run a child theme of Luma, our child theme only has some very minor layout changes and CSS.

Are there any really generous gurus out there that might have any idea what might be causing this issue?

Thanks in advance, Mathew

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.