0

Our main Dashboard page is not showing any data such as graphs etc. otherwise, the page renders and works correctly. The page used to work, but I had the theme and 2 extension developers work on the site and now it doesn't work. All developers say it wasn't them.

Dashboard screenshot here

Charts are enabled in Stores/configuration/advanced/admin/dashboard -> Enable Charts = Yes.

User has administrator rights.

Inspect Console shows no errors and there are no issues in logs.

I have run the following:

rm -rf pub/static/* var/cache/* var/composer_home/* var/tmp/* var/view_preprocessed/* var/page_cache/* generated/code generated/metadata 

php71 bin/magento setup:upgrade
php71 bin/magento setup:di:compile
php71 bin/magento setup:static-content:deploy en_AU en_US
php71 bin/magento cache:flush

php71 bin/magento cron:run

Has anyone got any idea what might be causing this? Could it be something simple switched off that I'm not aware of?

We were going live with our site very soon but can't with this issue.

  • From your screenshot. it doesn't seem like this is magento default dashboard. Is there any extension which you are using for dashboard reports. – nishu Oct 9 at 7:01
  • @nishu I don't have any third party reports installed, but the site won't let me change the dashboard startup page via stores/settings/configuration/advanced/admin/startup page. It keeps going to /mpreports/dashboard. Do you know what mpreports is? Is it a magento admin url? – Todd Robards Oct 9 at 23:41
  • Huh, Mageplaza Reports snuck into our system when installing something else from Mageplaza... It doesn't work on our system and leaves the dashboard as blank. – Todd Robards Oct 10 at 0:08
0

Mageplaza Reports snuck into our system when installing something else from Mageplaza...

Mageplaza Reports over-rides all the dashboard startup pages, and doesn't work on our system and leaves the dashboard as blank. I disabled Mageplaza reports and the dashboard came back.

I will contact Mageplaza to see if they can fix their module.

Normally Mageplaza modules/extensions work well for us.

  • great.. good to hear at-least we have found the root cause of the problem. – nishu Oct 10 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.