0

I've got a Magento 2 dev installation all setup, I've pulled from my repo and setup the site.

The frontend seems to be working OK, I can see information being pulled from the database.

The issue is when I try and do anything in the admin, it's just broken, the Magento logo isn't showing on the top left and none of the sub-menus is working.

I have this error in the console:

http://domain.co.uk/static/version1570049246/adminhtml/Magento/backend/en_US/requirejs/require.js net::ERR_ABORTED 404 (Not Found)

I've tried setting the site to developer mode, clearing cache, upgrading and compiling again but with no such luck.

Any help would be great.

EDIT

After looking in this folder:

pub/static/adminhtml/Magento/backend/en_US/requirejs

I can't see the require.js file, does this need to be symlinked?

  • Try this php bin/magento setup:static-content:deploy --area adminhtml – PЯINCƏ Oct 2 '19 at 23:44
  • also please check if your pub/static has .htaccess file. – Rizwan Khan Oct 3 '19 at 5:19
  • Thanks @RizwanKhan there is a .htaccess there. – WebDevB Oct 3 '19 at 8:10
  • Thanks @PЯINCƏ I've tried that but unfortunately, it's not worked. – WebDevB Oct 3 '19 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.