5

http://i.stack.imgur.com/m9CSW.png

I think the picture is explaining the problem. I did a research and I simply have not enough time to create another 4 stores and set over 200 articles again and again. I would agree on removing the "Your credit card will be charged for" line completely, or change the functionallity to show the currency which was chosen by the customer.

Hope you can help :)

  • Did you solve your issue? – Gem Jun 11 '18 at 4:42
6

the line with the base grand total appears if you have the store view currency different from the default currency. If you want to remove that line either you set the base currency to be the store currency, but I guess that's not an option because you already have the prices filled in or...
you can override this method: Mage_Checkout_Block_Cart_Totals::needDisplayBaseGrandtotal() and always make it return false.

[Update]
For this create your own extension. Let's call it Easylife_Checkout (feel free to change the namespace) with the following file: app/etc/modules/Easylife_Checkout.xml

<?xml version="1.0"?>
<config>
    <modules>
        <Easylife_Checkout>
            <active>true</active>
            <codePool>local</codePool>
            <depends>
                <Mage_Checkout />
            </depends>
        </Easylife_Checkout>
    </modules>
</config>

app/code/local/Easylife/Checkout/etc/config.xml

<?xml version="1.0"?>
<config>
    <modules>
        <Easylife_Checkout>
            <version>0.0.1</version>
        </Easylife_Checkout>
    </modules>
    <global>
        <blocks>
            <checkout>
                <rewrite>
                    <cart_totals>Easylife_Checkout_Block_Cart_Totals</cart_totals><!-- this tells Magento to use your block instead the default one-->
                </rewrite>
            </checkout>
        </blocks>
    </global>
</config>

app/code/local/Easylife/Checkout/Block/Cart/Totals.php

<?php 
class Easylife_Checkout_Block_Cart_Totals extends Mage_Checkout_Block_Cart_Totals{
    public function needDisplayBaseGrandtotal(){
        return false;
    }
}

Clear the cache and disable the compilation if it's enabled.

  • In what files do I have to do that and how exactly? I am still learning :) – Alex Rosh Apr 11 '13 at 8:08
  • I've updated the answer with the code you need. – Marius Apr 11 '13 at 9:00
  • 1
    This works for the checkout confirmation page, but when you're redirected to the payment provider, e.g. PayPal, still the base currency amount is transferred. – Nick Weisser Feb 4 '15 at 15:46
2

This message appears at the end of checkout and in the order emails. One solution might be to just hide it. (That's what I did.)

Checkout page

app/design/frontend/[your package]/[your theme]/template/checkout/onepage/review/totals.phtml

Just comment these lines:

<?php /* if ($this->needDisplayBaseGrandtotal()):?>
    <tr>
        <td class="a-right" colspan="<?php echo $_colspan; ?>">
            <small><?php echo $this->helper('sales')->__('Your credit card will be charged for') ?></small>
        </td>
        <td class="a-right">
            <small><?php echo $this->displayBaseGrandtotal() ?></small>
        </td>
    </tr>
<?php endif */ ?>

Order email

app/code/community/Mage/Sales/Block/Order/Totals.php

About line 149, comment the complete if with isCurrencyDifferent():

/*
if ($this->getOrder()->isCurrencyDifferent()) {
    $this->_totals['base_grandtotal'] = new Varien_Object(array(
        'code'  => 'base_grandtotal',
        'value' => $this->getOrder()->formatBasePrice($source->getBaseGrandTotal()),
        'label' => $this->__('Grand Total to be Charged'),
        'is_formated' => true,
    ));
}
*/
  • Just clarify myself, if i add comment line make sure no other file will affect? – Gem Jun 11 '18 at 4:49
  • I am getting error like : Parse error: syntax error, unexpected 'public' (T_PUBLIC) in /home/abcd/public_html/app/code/community/Mage/Sales/Block/Order/Totals.php on line 168 – Gem Jun 11 '18 at 9:14
-1

First you have to go to the

admin panel -> System -> Configuration -> CATALOG -> Catalog -> Price -> Catalog Price Scope and change it from Global to Website.

Now when you go to the

admin panel -> System -> Configuration -> GENERAL -> Currency Setup -> Currency Options you can change Base Currency per Website, not only for Default (Global).

So you have to transfer you stores to websites and you will be able to do what you want.

  • Still same error... – Gem Jun 11 '18 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.