0

I've recently set my site up with Varnish full_page cache, and I have one specific URL that seems to be "stuck" and I am not able to clear it from the cache.

Last night I went into maintenance mode to do some updates, and this morning one URL is still showing the maintenance page, I guess because it got crawled while the site was down. All the other URLs I've tested are working but this specific one won't load.

This is production so I don't want to do anything crazy, I just want to clear that one page's cache and nothing I've tried works.

I have tried restarting Varnish at the command line but that does not work. Nor does clearing Magento cache on the front end.

I can disable full_page cache at the command line, and then I can see that the page loads properly. Then I restarted Varnish, and turned full_page cache back on, and the page then responded once again with the "Maintenance" page. So Varnish is hard-caching the page response, but how do I purge it?

Magento 2.3.2 and Varnish 6.0.3

0

I normally use following command:

curl -v -X PURGE -H 'X-Magento-Tags-Pattern: .*' http://your_magento_domain_name
0

I thought this URL was caching the maintenance page, but that wasn't the case. This specific page was actually crashing when varnish was enabled because of this Magento issue with too-long cache headers.

My fix is described in my response to this issue: Magento 2.3.1 - Issue with catalog search when using php7.2-fpm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.