0

1 exception(s): Exception #0 (Magento\Framework\Exception\LocalizedException): Please upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory. The following modules are outdated: Amazon_Core schema: current version - 2.1.3, required version - 2.2.14 Amazon_Core data: current version - 2.1.3, required version - 2.2.14 Amazon_Login schema: current version - 2.1.3, required version - 2.2.14 Amazon_Login data: current version - 2.1.3, required version - 2.2.14 Amazon_Payment schema: current version - 2.1.3, required version - 2.2.14 Amazon_Payment data: current version - 2.1.3, required version - 2.2.14 Magento_CatalogWidget schema: current version - 2.0.0, required version - 2.0.1 Magento_CatalogWidget data: current version - 2.0.0, required version - 2.0.1 Dotdigitalgroup_Email schema: current version - 2.7.1, required version - 2.7.2 Dotdigitalgroup_Email data: current version - 2.7.1, required version - 2.7.2

7
  • if you want help, help us to understand what you did, and what you want – PЯINCƏ Sep 24 '19 at 14:52
  • please help me this message coming up – Ratheesh V.R Sep 24 '19 at 14:55
  • What did you do to get this message ? – PЯINCƏ Sep 24 '19 at 14:56
  • this is my site www.yoursaw.co.uk – Ratheesh V.R Sep 24 '19 at 14:57
  • Try to execute this : php bin/magento setup:upgrade in CLI – PЯINCƏ Sep 24 '19 at 14:59
0

it seems to me that you have updated the Amazon module, please run this :

php bin/magento setup:upgrade
0

Please remove Amazon_Core module entry from the setup_resource table of the database and run below command in the command line. Open cmd and go to the Magento project folder like C:\xampp\htdocs\magento and run below command.

php bin/magento setup:upgrade

Still, you are facing the issue please let me know.

Hope this will help you.

0

I'm not entirely sure but this could be a module version error.

I have recently encountered this when my data_version was altered accidentally while creating a new module.

I had to update/reset the module version within these areas on the Database:

update setup_module set schema_version = "1.0.x" where module = "Your_Module"; update eav_attribute set data_version = "1.0.x" where module = "Your_Module";

However, I agree with @PЯINCƏ that a setup:upgrade is required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.