2

I had a lot of problems with the Export and Import of Products through a CSV file.

My main issue is that in Germany MS Excel generally uses ";" as a delimiter instead of ",". I tried a few work arounds, but in the end now I changed Mangeto's delimiter settings so I export and import with ";" as delimiter, now the CSV file is beeing correctly displayed in MS Excel. 1. Question: What do you think about that?

A lot of products use the "Ø"-sign for the diameter of our round carpets in the shop, yes we sell carpets by the way. I got the error "sku is not defined" for around 200/500 rows, I found out that this issue is due to the "Ø", because when I replaced this sign, everything worked fine. The strange thing about that is, that I am pretty sure, well 99,9% sure, the import of products with "Ø" in the name worked before. It may be that I had different System settings for Windows and maybe different coding settings in MS Excel, everything got a little bit confused and changed, maybe that is the reason. 1. Question: Do you know if it is possibe for me to import with special characters like "Ø" and if yes, how? Btw I use "alt" + "0216" (German keyboard) for this sign.

Kai

1

Look into UTF-8 Encoding

You should be able upon saving the MS Excel doc to use , instead of ; without any repercussions. I believe you can also provide an escape sequence or text delimiter such as " to allow for either , or ; in context without it being treated as a delimiter.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.