1

I have tried using below command but getting errors when update

Command 1:

composer require magento/product-community-edition 2.3.0 --no-update

Command 2:

composer update

Output:

 Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
    - magento/product-community-edition 2.3.0 requires elasticsearch/elasticsearch ~2.0|~5.1 -> satisfiable by elasticsearch/elasticsearch[2.0.x-dev, v2.0.0, v2.0.0-beta1, v2.0.0-beta2, v2.0.0-beta3, v2.0.0-beta4, v2.0.0-beta5, v2.0.1, v2.0.2, v2.0.3, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.2.2, v2.2.3, v2.3.0, v2.3.1, v2.3.2, v2.4.0, v5.1.0, v5.1.1, v5.1.2, v5.1.3, v5.2.0, v5.3.0, v5.3.1, v5.3.2, v5.4.0, v5.5.0] but these conflict with your requirements or minimum-stability.

if anyone has an idea help me..!!!

  • What is your elasticsearch version ? Check if your elastic search version is compatible with Magento community-edition 2.3.0 – MGento Sep 19 at 4:43
0

I have also faced this issue for this you have to follow this steps:

Please Cross Check the requirements, this issue arises once your requirement does not meet with server configurations.

Please cross check your PHP version and all other requirement with this link : Click Here

Also if this not resolved, First Backup your Vendor Folder then Delete it, After run Composer commands such as

composer install
composer update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.