1

We have successfully migrated data from M1 to M2 using the data migration tool. We have a custom table called md_cybersource which is mapped to magedelight_cybersource in map.xml

When we run delta migration getting below error message

' Base table not found 1146 table m1_compressed.m2_cl_md_cybersource'  doesn't exist query was m2_cl_md_cybersource where ('processed'=1)

Base table view not found 1146 table m1_compressed.m2_cl_md_cybersource doesn't exit'

Observation is Searched trigger table in M1 which is not created. Please suggest or advise how to fix & why it is happen?

1

We have 2options for that

First : try with ignore documents in map.xml

<source>
    <document_rules>
        <ignore>
            <document>magedelight_cybersource</document>
        </ignore>
</source>

Second : its tricky solution export only table ( not data ) from m1 and import in m2 like : m2_cl_md_cybersource than try with delta command.

Try with above options its work for you

| improve this answer | |
  • actually, for the custom tables data migration tool needs are to create a triggers table at the time of data migration am I correct? – Nagaraju K Sep 17 '19 at 5:53
  • yes, if you create table in m2 than error not found. – Anas Mansuri Sep 17 '19 at 6:38
0

in map.xml file

<source>
    <document_rules>
        ...
        <!-- Ignore `magedelight_cybersource` table -->
        <ignore>
            <document>magedelight_cybersource</document>
        </ignore>
        ...
</source>

I hope so it's useful for you.

| improve this answer | |
  • actually I have to map this table (md_cybersource) to magedelight_cybersource that i already did in the map.xml its working as expected. but when i execute delta i found there is no table was created in m1 db with m2_cl_md_cybersource. – Nagaraju K Sep 17 '19 at 5:49
0

Reason - It contains Prefix 'm1_'.

Solution - we need to add for resolve this error.

Ex: <source_prefix>m1_</source_prefix>

| improve this answer | |
  • so by adding only prefix for source will resolve the error? or we must add same prefix for destination also? – jafar pinjar Jan 10 at 7:29
  • yes exactly!! if you want you can add prefix for destination also but if you leave it blank, this will use without prefix names. – Oscprofessionals Jan 13 at 10:21
0

I have figured out the issue and resolved it by adding the below piece of code in the below-mentioned file.

<document key="card_id">md_cybersource</document> 

File Name: vendor/magento/data-migration-tool/etc/commerce-to-commerce/1.14.3.1/deltalog.xml

Syntax:

<?xml version="1.0" encoding="UTF-8"?>
<!--
/**
 * Copyright © Magento, Inc. All rights reserved.
 * See COPYING.txt for license details.
 */
-->
<groups xmlns:xs="http://www.w3.org/2001/XMLSchema-instance" xs:noNamespaceSchemaLocation="../groups.xsd">
    <group name="delta_map">
               <document key="card_id">md_cybersource</document>
   </group>
  </groups>

So that it has been creating an m2_cl_md_cybersource triggers/data table at the time data migration in the M1 database.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.