2

I have configured php_mcrypt, still getting same error.

enter image description here

How to solve the error?

Note : phpinfo not showing details about mcrypt.

10
  • 1
    Restart the Wampp server and try again.
    – Sumit
    Sep 16 '19 at 11:52
  • yes, i did still getting the same error.
    – Gem
    Sep 16 '19 at 11:52
  • FYI - My phpinfo not showing mcrypt
    – Gem
    Sep 16 '19 at 11:53
  • for php my_crypt, check with the phpinfo whether it is enabled or not & also please flush the cache & check the version of php. Sep 16 '19 at 11:55
  • 1
    FYI to all: Downgrade my version 7.2.18 to 7.1.29, after installed successfully then upgraded my version back to 7.2.18, now working, i don't know what happened, anyone knows pls explain?
    – Gem
    Sep 16 '19 at 12:30
0

Warning : This feature was DEPRECATED in PHP 7.1.0, and REMOVED in PHP 7.2.0.

Alternatives to this feature include:

  • Sodium (available as of PHP 7.2.0)
  • OpenSSL

https://www.php.net/manual/en/intro.mcrypt.php

8
  • My php ver 7.2.18
    – Gem
    Sep 16 '19 at 12:22
  • 1. Stop All Services 2. Start All Services And check Again Sep 16 '19 at 12:30
  • I did all possibilities no help, finally do some changes in versions worked, even i don't know what happened.
    – Gem
    Sep 16 '19 at 12:32
  • okay now you can just find "mcrypt " in php extension 7.2.18 it's display or not? Sep 16 '19 at 12:34
  • no, it's not showing, but my Magento installed.
    – Gem
    Sep 16 '19 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.