4

I've migrated my Magento CE 1.7.0.2. to a new domain and have updated the local.xml and core_config_data table, web/unsecure/base_url and web/secure/base_url now contain the right urls. (Installation 1)

However upon opening the main page of my store I do get the following error:

There has been an error processing your request

Invalid URI supplied

a:5:{i:0;s:20:"Invalid URI supplied";i:1;s:871:"#0 /home/my-domain.com/public_html/lib/Zend/Uri.php(143): Zend_Uri_Http->__construct('http', '//my-domain...')
#1 /home/my-domain.com/public_html/app/code/core/Mage/Core/Model/Store.php(726): Zend_Uri::factory('http://my-doma...')
#2 /home/my-domain.com/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(313): Mage_Core_Model_Store->isCurrentlySecure()
#3 /home/my-domain.com/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(161): Mage_Core_Controller_Varien_Front->_checkBaseUrl(Object(Mage_Core_Controller_Request_Http))
#4 /home/my-domain.com/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#5 /home/my-domain.com/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#6 /home/my-domain.com/public_html/index.php(87): Mage::run('', 'store')
#7 {main}";s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

The url of my Magento installation contains dashes but no underscores.

I've successfully installed a clean Magento installation (Installation 2) on the same server using a second database. This installation runs without problems, settings of the web/unsecure/base_url and web/secure/base_url in the core_config_data table are equal.

I've also configured the clean installation (Installation 2) in such a way that it links to the database of the original Magento installation (Installation 1) surprisingly this works fine too.

I feel something is wrong with one of the Magento files of Installation 1. Anybody a clue what might cause installation 1 not to work properly?

6

Check any whitespace or new line character on core_config_data table entries for base_url fields (web/unsecure/base_url, web/secure/base_url, web/unsecure/base_url, web/secure/base_url). I encountered this once and that's how I've resolved it.

Also another error that you may get because of this mistake is

Warning: Header may not contain more than a single header, new line detected  in lib/Zend/Controller/Response/Abstract.php on line 363

I would like to add this as comment but I don't have enough reputation to do so.

0

I had the same issue and my URL didn't have an underscore "_" in it. So the solution was to erase the var/cache folder contents and also the var/session folder content. Then refresh your page and that should do it.

0

Spent quite some time resolving this issue today. The Magento 2 site we were working on would not load the admin area and was exhausting all available memory. The URL was edited in the DB and had a line break after the domain name.

Check the URLS in web/unsecure/base_url & web/secure/base_url

Make sure they are clean with no spaces etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.