0

We are trying to upgrade a Magento 2.2.2 site to Magento 2.3.2, when executing **php bin/magento indexer:reindex** we get the error...

Design Config Grid index has been rebuilt successfully in 00:00:00
Customer Grid index is locked by another reindex process. Skipping.
Category Products index has been rebuilt successfully in 00:00:04
Product Categories index has been rebuilt successfully in 00:00:00
Catalog Rule Product index has been rebuilt successfully in 00:00:00
Product EAV index has been rebuilt successfully in 00:00:01
Stock index has been rebuilt successfully in 00:00:00
PHP Fatal error:  Uncaught Error: Call to undefined method Magento\Catalog\Model\ResourceModel\Product\Indexer\Price\SimpleProductPrice::reindexAll() in /var/www/html/app/code/Bss/MultiStoreViewPricingPriceIndexer/Model/Indexer/Product/Price/Action/Full.php:51
Stack trace:
#0 /var/www/html/vendor/magento/module-catalog/Model/Indexer/Product/Price.php(66): Bss\MultiStoreViewPricingPriceIndexer\Model\Indexer\Product\Price\Action\Full->execute()
#1 /var/www/html/vendor/magento/module-indexer/Model/Indexer.php(416): Magento\Catalog\Model\Indexer\Product\Price->executeFull()
#2 /var/www/html/vendor/magento/module-indexer/Model/Indexer/DependencyDecorator.php(248): Magento\Indexer\Model\Indexer->reindexAll()
#3 /var/www/html/vendor/magento/module-indexer/Console/Command/IndexerReindexCommand.php(87): Magento\Indexer\Model\Indexer\DependencyDecorator->reindexAll()
#4 /var/www/html/vendor/symfony/console/Command/Command.php(255): Magento\Indexer\Console\Command\IndexerReindexCommand->execute(Object(Symfony\Component\Console\Input\Argv in /var/www/html/app/code/Bss/MultiStoreViewPricingPriceIndexer/Model/Indexer/Product/Price/Action/Full.php on line 51

the error message enter link description here

4
  • Seems issue with BSS-Multi store view pricing module. Disable it first then upgrade
    – Jackson
    Sep 13, 2019 at 9:46
  • after that enable again ? Sep 13, 2019 at 9:55
  • You need to check with module vendor weather they have compatible version of that module or not? otherwise you need to add that patch.
    – Jackson
    Sep 13, 2019 at 9:56
  • - how to check that ? - if not want i can do ? - which patch ? Sep 13, 2019 at 10:00

2 Answers 2

0

issue is not related to the magento

the third party extension is not compatible with magneto2.3.2

first disable the extension BSS_MultiStoreViewPricingPriceIndexer and clear cache and run the indexer command again

5
  • after that enable again ?????? Sep 13, 2019 at 9:55
  • no please install magento2.3.2 compaitible extension, or contact extension provide to provide you updated package Sep 13, 2019 at 10:00
  • how can i do that Sep 13, 2019 at 10:01
  • please get the updated package from bss company, that is compaitible with magento 2.3.2 Sep 13, 2019 at 10:04
  • please provide me with link or command please Sep 13, 2019 at 10:07
0

from what I experienced while, I was upgrading Magneto, It could be one of theses things: app/code/Bss/MultiStoreViewPricingPriceIndexer/Model/Indexer/Product/Price/Action/Full::execute()

  • may use a removed method.
  • may a method that its encapsulation (from protected to private) was changed .
  • may use a removed property.
  • may use a property with changed encapsulation (from protected to private).
  • may use a method that has it extensions changed.

The easiest fix is to check if the third party extension has new version compatible with Magento 2.3.2, if that the case swap it with older one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.