2

I have added the following data to my app/etc/config.php file:

'scopes' => [
    'websites' => [
        'admin' => [
            'website_id' => '0',
            'code' => 'admin',
            'name' => 'Admin',
            'sort_order' => '0',
            'default_group_id' => '0',
            'is_default' => '0'
        ],
        'website_1' => [
            'website_id' => '1',
            'code' => 'website_1',
            'name' => 'website_1',
            'sort_order' => '0',
            'default_group_id' => '1',
            'is_default' => '1'
        ],
        'website_2' => [
            'website_id' => '2',
            'code' => 'website_2',
            'name' => 'website_2',
            'sort_order' => '0',
            'default_group_id' => '2',
            'is_default' => '0'
        ]
    ],
    'groups' => [
        [
            'group_id' => '0',
            'website_id' => '0',
            'name' => 'Default',
            'root_category_id' => '0',
            'default_store_id' => '0',
            'code' => 'default'
        ],
        [
            'group_id' => '1',
            'website_id' => '1',
            'name' => 'group_1',
            'root_category_id' => '2',
            'default_store_id' => '1',
            'code' => 'group_1'
        ],
        [
            'group_id' => '2',
            'website_id' => '2',
            'name' => 'group_2',
            'root_category_id' => '2',
            'default_store_id' => '2',
            'code' => 'group_2'
        ]
    ],
    'stores' => [
        'admin' => [
            'store_id' => '0',
            'code' => 'admin',
            'website_id' => '0',
            'group_id' => '0',
            'name' => 'Admin',
            'sort_order' => '0',
            'is_active' => '1'
        ],
        'en_gb' => [
            'store_id' => '1',
            'code' => 'store_1',
            'website_id' => '1',
            'group_id' => '1',
            'name' => 'store_1',
            'sort_order' => '0',
            'is_active' => '1'
        ],
        'store_2' => [
            'store_id' => '2',
            'code' => 'store_2',
            'website_id' => '2',
            'group_id' => '2',
            'name' => 'store_2',
            'sort_order' => '0',
            'is_active' => '1'
        ]
    ]
]

When running the the following CI command:

php bin/magento app:config:import

I am greeted with the following helpful error message:

$ php bin/magento app:config:import --no-interaction
Processing configurations data from configuration file...
Import failed: Validation Failed

Has anyone come across this issue before know how I can determine why the validation failed?

I've checked the logs and found nothing of use apart from the same super helpful error message repeated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.