0

I know there had been many queries regarding the topic and I went through almost all of it.

The point where my query is slightly different from the rest is that my magento website runs pretty well in the production.

But my localhost is painfully slow. A point I would like to mention is that the magento project is created by me, and I have started working on it recently. I am not sure if its a magento thing or there had been some fault on my part during setting up of the project in my system.

So, in the project everytime I open a new page, the first request takes a lot of time as shown below:

enter image description here

enter image description here

Since the production website runs well, that removes the possibility of any optimisation in the server side. Also, the localhost I saw running in other system in the organisation was loading pretty fast (some of the systems being a mac).

The data in my localhost is being fetched from the test database not having as many tuples as that of the production database. My system that I am using currently is Ubuntu 16.04, 8GB RAM and i5 8th gen. I am using PHP version 5.6.

Considering following scenarios mentioned, it will be really helpful if someone can point me to the reason why its happening. I am trying my level best so that the question is not a broad one, so if any details is required from my end which I missed to give, please ask for that.

  • Do you have SSD in your System? – oscprofessionals Sep 9 at 11:24
  • @oscprofessionals I am not sure about it now, I am looking. On running cat /sys/block/sda/queue/rotational it gives me 1 – arqam Sep 9 at 11:34
  • @oscprofessionals I searched the value 1 is when it uses HDD and not SSD. – arqam Sep 9 at 11:37
  • 1 means you are using hard disk. Magento has lots of files so system has to read a lot and without SSD this will always be an issue. Also on times some third party modules and response will delay like a Fedex call. SO make sure if these are blocking else take sql query log. – oscprofessionals Sep 9 at 11:39
  • @oscprofessionals Does it take so much time to load even in hdd, say for a fully functional website? – arqam Sep 9 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.