0

I had the site configured for shipping with Fedex just fine . . . then we tried implementing a "One Page Checkout" extension, and Fedex stopped working.

I have since turned off the extension, but no luck! I'm attaching a sample shipping log. I can see there is an error regarding "stdClass Object", but I have no idea where that would come from.
Please Help! Title: Fedex Soap Request/Response

Message:

Array ( [request] => Array ( [Version] => Array ( [ServiceId] => crs [Major] => 10 [Intermediate] => 0 [Minor] => 0 )

        [ReturnTransitAndCommit] => 
        [RequestedShipment] => Array
            (
                [DropoffType] => REGULAR_PICKUP
                [ShipTimestamp] => 2014-07-11T20:11:26+00:00
                [ServiceType] => 
                [PackagingType] => YOUR_PACKAGING
                [Shipper] => Array
                    (
                        [Address] => Array
                            (
                                [PostalCode] => 77303
                                [CountryCode] => US
                                [Residential] => 1
                            )

                    )

                [Recipient] => Array
                    (
                        [Address] => Array
                            (
                                [PostalCode] => 60044
                                [CountryCode] => US
                                [Residential] => 1
                            )

                    )

                [RateRequestTypes] => LIST
                [PackageDetail] => INDIVIDUAL_PACKAGES
                [RequestedPackageLineItems] => Array
                    (
                        [0] => Array
                            (
                                [GroupPackageCount] => 1
                                [Weight] => Array
                                    (
                                        [Value] => 5
                                        [Units] => LB
                                    )

                                [Dimensions] => Array
                                    (
                                        [Length] => 25
                                        [Width] => 36
                                        [Height] => 5
                                        [Units] => IN
                                    )

                            )

                    )

                [PackageCount] => 1
            )

        [WebAuthenticationDetail] => Array
            (
                [UserCredential] => Array
                    (
                        [Key] => jXXXXXXXXXXXXXXL
                        [Password] => XXXXXXXXX
                    )

            )

        [ClientDetail] => Array
            (
                [AccountNumber] => XXXXXXXXX
                [MeterNumber] => XXXXXXXXX
            )

    )

[result] => stdClass Object
    (
        [HighestSeverity] => ERROR
        [Notifications] => stdClass Object
            (
                [Severity] => ERROR
                [Source] => prof
                [Code] => 1000
                [Message] => Authentication Failed
            )

        [Version] => stdClass Object
            (
                [ServiceId] => crs
                [Major] => 10
                [Intermediate] => 0
                [Minor] => 0
            )s
  • [Message] => Authentication Failed – dockeryZ Nov 7 '14 at 16:14
1

You need to check your account details, and ensure you are pointing to the correct environment for those details (live or sandbox). Its nothing to do with your checkout changes.

  • My credentials correct, i have two store in single magento, store 1 display Fedex shipping cost, but store 2 not displaying shipping cost, how can i solve this issue? – zus Mar 10 '18 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.