1

Magento 2.3.1 / Windows 10 / WAMP64

Start Magento Admin / System Upgrade

ERROR:

"PHP Settings Check

Your current PHP memory limit is 2G. Magento 2 requires it to be set to 756M or more.

As a user with root privileges, edit your php.ini file to increase memory_limit.

(The command php --ini tells you where it is located.) After that, restart your web server and try again"

enter image description here

I set memory limit 6G in the php.ini & htaccess & user.ini files.

No result.

Can help to me ?

  • while runing Magento 2 Commands then seen memory limit error? – Savan Patel Aug 27 at 12:18
  • Do you restart the WAMP after change the memory limit ? – St3phan Aug 27 at 12:22
  • which htaccess? there are multiple – Philipp Sander Aug 27 at 12:39
  • 1. I runing Magento Admin -> System Upgrade. 2. I see htaccess files in magento directory and edit this with "php_value memory_limit". 3. I restarted Apache and WAMP64 services many times. No result – Georgi Aug 27 at 15:12
  • Did you edit the php.ini file in the correct location ? – Sourabh Kumar Sharma Aug 29 at 6:34
0

Try restarting your apache and server, and then check again

  • I restarted Apache and WAMP64 services many times. No result. – Georgi Aug 27 at 15:00
0

Maybe you set it in the wrong file. Try adding this line in the index file:

ini_set('memory_limit', '1024M')

Please let me know if this works

  • I've done it already in index.php on Magento. No effect: Error: "PHP Settings Check * Your current PHP memory limit is 2G. Magento 2 requires it to be set to 756M or more. As a user with root privileges, edit your php.ini file to increase memory_limit. (The command php --ini tells you where it is located.) After that, restart your web server and try again." – Georgi Aug 28 at 5:52
0

I found a solution.

Run:

php bin/magento cron:run

php update/cron.php

php bin/magento setup:cron:run

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.