1

I am getting the error in Magento 2 installation.

** Error:**

enter image description here

6
  • You're missing libsodium php extension it seems, it is required for 2.3.2 version @vikaskumar Aug 27 '19 at 7:06
  • what is your php and magento version? Aug 27 '19 at 7:47
  • Php version 7.2.19 and Magento Version 2.3.2
    – user72883
    Aug 27 '19 at 8:10
  • libsodium extension is not mentioned on magento website @Prathap Gunasekaran
    – user72883
    Aug 27 '19 at 8:12
  • 1
0

If you are on ubuntu Install php-libsodium by entering the following commands in the terminal:

sudo apt update
sudo apt install php-libsodium

Restart the server and you can install then

0

In Ubuntu Install Phplibsodium by entering below commands:

wget https://download.libsodium.org/libsodium/releases/libsodium-1.0.18.tar.gz

tar -xzvf libsodium-1.0.18.tar.gz cd libsodium-1.0.18

./configure

make && make check

sudo make install

sudo /opt/lampp/bin/pecl install -f libsodium

sudo echo "extension=sodium" >> /opt/lampp/etc/php.ini

php -m | grep sodium

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy