0

When I'm in production mode, if i run the command

php bin magento setup: upgrade

static files are generated only for the en_US language. While for the other store views, it_IT and es_ES I get the error: unable to retrieve deployment of static files from the file system storeview

I have to generate manually with the command:  

php bin / magento setup: static-content: deploy - f it_IT

.... It's normal? Because when I'm in Developer mode and I run the command:

php bin magento setup: upgrade

They are automatically generated for all store view.

0

My understanding of the Magento documentation (link below) is that unless specified one language or all languages, en_US is the default language.

https://devdocs.magento.com/guides/v2.3/config-guide/cli/config-cli-subcommands-static-view.html

If you try the command below:

bin/magento setup:static-content:deploy it_IT es_ES

It should work and get something like this as a result:

Deploy using quick strategy
adminhtml/Magento/backend/it_IT         2193/2193           ============================ 100% %  10 secs
frontend/Magento/blank/it_IT            2180/2180           ============================ 100% %  9 secs
adminhtml/Magento/backend/es_ES         2193/2193           ============================ 100% %  11 secs
frontend/Magento/blank/es_ES            2180/2180           ============================ 100% %  9 secs
frontend/Magento/luma/it_IT             2195/2195           ============================ 100% %  12 secs
frontend/Magento/luma/es_ES             2195/2195           ============================ 100% %  12 secs
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.