3

We have upgraded our Magento installation to 2.3.2 from 2.1.16 and the password validation when creating a customer account in the frontend doesn't work.

When I enter the following password " Qwerty12! " so it has all the requirements it says and keeps on saying password: Weak:

Minimum length of this field must be equal or greater than 5 symbols. Leading and trailing spaces will be ignored.

Here is a screenshot to make it more clear:

enter image description here

Also in the console, I see the following error when I type:

$.validator.methods[method] is undefined

The error is located in ValidateSingelElement in the validations.min.js and in the _calculateStrength in the password-strength-indicator.min.js

  • Even when it's working Magento does class that as a weak password, what if you try Qwerty12!#5Jehs**() as the password? That should return as very strong. As for the error have you overwritten that file anywhere or has any module done so? – Ben Crook Sep 2 at 15:27
1
+50

It's not an error ideally. you are trying to set a password with the sequence of 6 letters of the keyboard which is easily predictable by hackers and though due to security reason it's giving you an error that its a weak password. If you change one latter with any of other latter which is not in sequence its work fine.

ex. "Qaerty12!" it will not give you an error. same way if you use "Asdfgh12!" again it will give you an error as ASDFGH are in same row.

Hope it will help you!!

  • It is still not working, even if i just put random numbers, letters and special characters in the field. – Wouter Stulp Sep 3 at 8:47
  • can you please provide error which appearing in the console – poojan sharma Sep 3 at 8:53
  • imgur.com/jecR5Nv see the error I have in console – Wouter Stulp Sep 3 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.