0

It is not recommended to specify supported PHP versions in dependencies. If specified, it must at least match the PHP requirements of the supported Magento versions.

  • what you want to ask please elaborate in detail – ASQ Aug 26 at 6:52
  • Basically i am working on extension development .when i validate it by market-place tool ,terminal show this type of message ? – usman Aug 26 at 6:54
  • you specified the php vesion in dependencies? – ASQ Aug 26 at 6:55
  • this is my composer.json file code { "name": "esparksinc/extension", "description": "N/A", "type": "magento2-module", "version": "1.0.0", "license": [ "OSL-3.0", "AFL-3.0" ], "require": { "php": "~7.0.13|~7.1.0|7.2.*", "magento/framework": "101.0.*|102.0.*" }, "autoload": { "files": [ "registration.php" ], "psr-4": { "Esparksinc\\Extension\\": "" } } } – usman Aug 26 at 6:56
  • 1
    yes it is not necessary – ASQ Aug 26 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.