0

I've tried disabling the temando module but i'm still getting the error.

Repositories code generation... 1/7 [====>-----------------------]  14% < 1 sec 74.0 MiB
Fatal error: Declaration of Temando\Shipping\Webservice\Processor\OrderOperation\PickupLocationRatesProcessor::postProcess(Magento\Quote\Model\Quote\Address\RateRequest $rateRequest, Temando\Shipping\Model\OrderInterface $requestType, Temando\Shipping\Webservice\Response\Type\QualificationResponseType $responseType) must be compatible with Temando\Shipping\Webservice\Processor\OrderOperation\RatesProcessorInterface::postProcess(Magento\Quote\Model\Quote\Address\RateRequest $rateRequest, Temando\Shipping\Model\OrderInterface $requestType, Temando\Shipping\Webservice\Response\Type\OrderResponseTypeInterface $responseType) in /srv/public_html/vendor/temando/module-shipping-m2/Webservice/Processor/OrderOperation/PickupLocationRatesProcessor.php on line 27

As you can see it starts to run but then bombs out 14% into the compile.

Any help would be greatly appreciated. Thank you.

1
  1. CD into the vendor folder.
  2. rm -rf temando/
  3. composer update
  4. n98-magerun2 setup:upgrade
  5. n98-magerun2 setup:di:compile
  6. n98-magerun2 setup:static-content:deploy
  7. n98-magerun2 setup:static-content:deploy en_US en_GB (Static deploy often requires you designate your language packs as well otherwise it may not deploy properly.)
  8. n98-magerun2 cache:flush
  9. n98-magerun2 cache:disable
  10. n98-magerun2 cache:enable

Obv. if you don't have n98 tools installed then just run normal php bin/magento whatever.

Cheers! Hope that works for you.

  • composer update is need to run ? – KGR Jun 11 '20 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.