0

So here is a strange thing: we uploaded a few thousand products but some products refused to show up in the front end. All products were enabled and had stock inventory. I reindexed a dozen times, cleared cache, tried everything. The products acted like they weren’t enabled, even trying to open them with the url address didn’t work. I finally managed to resolve the issue by disabling, saving and then re-enabling them. With this the products did show up as out of stock products. I changed the quantity, saved and voila the product was there.

Question is: did anybody face this issue and what should I do, because I can’t go over 8000 products enabling them one by one and setting the quantities manually.

Running magento 2.3.1

  • have you tried doing a mass update of the status for all products then doing a reindex? the resave may force the qty data to be updated at the same time – Dava Gordon Aug 21 at 14:53
  • Tried this sollution, it didn't work. I first disabled the products and then re-enabled them. In the backend they show up correctly, in the database they show as active, but they would not display for anything on the front end. I reindex everything via terminal, cleared the cache, same result. – Andras Aug 26 at 15:34
  • Try adding a product manually if that works it means one of the links most likely product to store are not set. Please try and let me know your result – Dava Gordon Aug 26 at 19:50
  • If I add manually it works. Most of the products work, we have problems with just two CSV files, both of them contain 1000+ entries. Here is another strange issue: the disable and reenabling only has effect on products that were added manually or for what I deactivated and activated manually. In the database all the products in question have the correct values, they are correctly updated after the import process. Reindexing and clearing the cache doesn’t give any errors, still the products are still not shown on front end. I will delete all these products and reimport them in smaller batches. – Andras Aug 26 at 20:43
  • Try exporting see if they all products come out. – Dava Gordon Aug 26 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.