4

I have disabled Google Recaptcha for Customer and Admin in Magento 2 backend and I also disabled the module with

bin/magento msp:security:recaptcha:disable

but no matter which shop page I load, I always see requests towards

https://www.gstatic.com/recaptcha/api2/v1563777128698/recaptcha__de.js https://www.google.com/recaptcha/api.js?onload=globalOnRecaptchaOnLoadCallback&render=explicit

I do not want to have these requests due to GDPR and in general, if I disable a service, I expect this to happen and not having any backdoor which still pulls code from somewhere.

Has someone an idea where these requests are coming from and how I can disable them?

Shop Version: Magento 2.3.2 Open Source

Thank you!

0

We had the same problem we had and were trying the exact same approach you did. In the end, we solved it by not just disabling the module but by uninstalling it. In our case it had a dependency on a PayPal module which we uninstalled as well.

So with the Magento CLI commands:

bin/magento module:disable Magento_PaypalReCaptcha
bin/magento module:disable MSP_ReCaptcha

Followed by the usual:

bin/magento setup:di:compile
bin/magento cache:flush

From there on, the browser was no longer reporting any kind of calls to google.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.