0

Please, can someone clarify for me Magento 2.2.9 Community Edition Which Elasticsearch Version can be used with it?

I have Amasty Elasticsearch extension installed - Tests are successful with both Elasticsearch version 5 and 6

I have tried 6.0 but it crashing the whole server at reindexing.

Version 5.0 works but is very very slow.

On the devdocs it's confusing

Magento 2.3.1 adds support for Elasticsearch 6.x, and it is enabled by default. Magento still provides modules for Elasticsearch 2.x and 5.x, but these must be enabled in order to use these versions. Elasticsearch 2.x is still available but strongly discouraged. Versions 2.x and 5.x are End of Life. If you must run Elasticsearch 2.x or 5.x with Magento 2.3.1, you must downgrade the Elasticsearch client to an older version. Follow the instructions in Change the Elasticsearch Client.

Then also mentions

https://devdocs.magento.com/guides/v2.2/config-guide/elasticsearch/es-downgrade.html

Magento 2.2.8 adds support for Elasticsearch (ES) 6.x. Magento still provides connectivity for ES 2.x and 5.x, but you must manually enable this support.

Am I getting confused between community edition and other Magento versions? Can someone please let me know or provide the URL link for elasticseach on community edition version 2.2.9

  • save yourself from the torment of selecting dependencies. just keep your software uptodate. – MagenX Aug 10 at 12:49
  • yes I agree in an ideal situation upgrade to latest version for all software and extensions is best but it is not possible for me at this moment in time hence the question posed here – jt9489 Aug 12 at 12:43
  • from your questions you are probably looking for some kind of compromise than the right solution ... – MagenX Aug 12 at 13:01
0

Magento CE 2.2.9 Open source edition not supporting any elastic search versions as per their GitHub repo and documentation (See the left section of dev docs).

Elasticsearch only supports in Magento Commerce 2.2.9 or Magento CE/EE 2.3.x. Devdocs recommends for Magento 2.2.8 with ES 2.x or 5.x also for Magento commerce only.

Go with Elasticsearch 6.x as the site is already using Amasty Elasticsearch Extension, Amasty should have a dependency to install elastic search package in the composer.json file. You should reach out to them(Amasty) for further any issues. But upgrade to latest Magento CE (2.3.2) is the best option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.