1

I cloned one gitlab project into the local system in windows. When I am running the project it shows the error like this. Vendor autoload is not found. Please run 'composer install' under the application root directory. Please tell what are the things to be done. And also why the files like env.php are missing in app/etc folders when cloning it from gitlab?

  • + for answer acceptance :) – Shoaib Munir Aug 13 at 5:06
1

Actually your vendor is empty, because it always added in .gitignore. To resolve this follow these steps

  1. Download and install composer for windows
  2. Run CMD and go to your project directory
  3. Run composer install. This will install all the required modules in vendor directory
  4. Now execute following commands and check after that

php -dmemory_limit=1G bin/magento setup:upgrade php -dmemory_limit=1G bin/magento setup:di:compile php bin/magento deploy:mode:set developer --skip-compilation php bin/magento setup:static-content:deploy -f php bin/magento cache:clean php bin/magento cache:flush

This should resolve your issue

  • Excellent. It worked very well. But admin page showing blank now after setup install. Can you tell how to solve that? – Kowsigan Atsayam Aug 9 at 16:37
  • 1
    turn on php error reporting, and check if your mode is development. Also check var/log/exception.log. By this you can get actual error – Shoaib Munir Aug 9 at 16:39
  • Did you resolve your issue? – Shoaib Munir Aug 9 at 17:31
  • Yes. Thank you very much – Kowsigan Atsayam Aug 12 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.