1

Server - Freebsd Server (Ngnix)

Install Memcached + Redis + 8 GB ram

Website name - http://mastersdirect.masters-sp.com/shop/customer/account/login/

But still, site taking too much time to load can you please guide what is the missing part?

env.php file.

Please check below env.php config files

 'session' => 
      array (
        'save' => 'memcached',
        'save_path' => '127.0.0.1:11211'
      ),
    'resource' => [
        'default_setup' => [
            'connection' => 'default'
        ]
    ],
    'x-frame-options' => 'SAMEORIGIN',
    'MAGE_MODE' => 'default',
    'cache_types' => [
        'config' => 1,
        'layout' => 1,
        'block_html' => 1,
        'collections' => 1,
        'reflection' => 1,
        'db_ddl' => 1,
        'eav' => 1,
        'customer_notification' => 1,
        'config_integration' => 1,
        'config_integration_api' => 1,
        'translate' => 1,
        'config_webservice' => 1,
        'compiled_config' => 1,
        'vertex' => 1
    ],
    'install' => [
        'date' => 'Mon, 12 Dec 2016 18:24:29 +0000'
    ],
    'cache' => [
        'frontend' => [
            'default' => [
                'backend' => 'Cm_Cache_Backend_Redis',
                'backend_options' => [
                    'server' => '127.0.0.1',
                    'database' => '0',
                    'port' => '6379',
                    'password' => ''
                ]
            ],
            'page_cache' => [
                'backend' => 'Cm_Cache_Backend_Redis',
                'backend_options' => [
                    'server' => '127.0.0.1',
                    'database' => '1',
                    'port' => '6379',
                    'compress_data' => '0',
                    'password' => ''
                ]
            ]
        ]
    ]
];
  • Have you tried putting your site to production mode ? – Abdul Pathan Aug 9 '19 at 10:51
  • Thanks for the response yes I tried with production mode also but did not impact so again switched back to the default mode – vijay raut Aug 9 '19 at 11:09
  • How many CPU cores? – Dominic Xigen Aug 9 '19 at 21:06
1

I checked this site in the console. I checked all JS(https://prnt.sc/oqhlv6).

http://mastersdirect.masters-sp.com/shop/pub/static/frontend/ASAD/masters/en_GB/tinyscrollbar.js this js taking around 5.1 sec and it goes to 403. Please remove this JS from your theme XML file to gain speed.

| improve this answer | |
1

Take a look at the response. Magento takes around 6 seconds to generate the page. wow

At first, check that production mode is enabled. Check the caches are enabled too. That account page is cacheable by default, but it doesn't seem like it uses cache to make a response, so maybe you have cacheable="false" somewhere that disables caching for the page.

Then try to install clean Magento 2 with sample data and measure the performance.

If clean Magento 2 works slow you need a better hosting. Otherwise, problem is related to your code customizations.

Try to disable some of your extensions, try to find a bottleneck using Magento 2 profiler. Mgt Developer Toolbar is a must have tool for measuring performance.

I myself found a great guide on the Internet with lots of recommendations and advices. Pease, check it here.

| improve this answer | |
  • Thanks, Bitrixhater for the response, I have set up one more environment with the same configuration but loading time is still high. Is there any missing configuration related to the server? Website link - waytomsp.masters-sp.com – vijay raut Aug 13 '19 at 8:25
0

I have resolved the issue.

The issue in the PHP configuration previously I have installed mod_php changed to the FPM so the performance of the website is improved.

Thanks, everyone for the support.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.