2

Please can someone clarify this for me

Does Magento 2.3.2 Work with PHP 7.1.30?

I have read on Devdocs 2.3 does work with PHP 7.1.30

But on a tutorial for a relaiable company was told Magento 2.3.1 ONLY works with PHP 7.2 - Is this correct or not?

0

Hello

Magento 2.3.x supports PHP 7.1.3 and 7.2. Magento 2.3.1 is also supported in PHP 7.2 and 7.1.3.

Thanks

2
  • Hi I wanto to know about version 2.3.2 specifically
    – jt9489
    Aug 5 '19 at 20:25
  • It should be work on the PHP 7.1.3 and 7.2
    – Moin Malek
    Aug 6 '19 at 7:19
0

I'm going to say no after installing magento 2.3 on a server with PHP 7.1.30 last week, I found that the initial set worked fine but had a number of issues with the installation running. I ended up upgrading the PHP version to 7.2 which worked a treat.

1
  • Thanks For me its the opposite I get numerous issue trying to run 2.3.2 with PHP 7.2 but not many running with PHP 7.1
    – jt9489
    Aug 5 '19 at 20:28
0

Yes

2.3.2

https://packagist.org/packages/magento/community-edition

See link. Packagist allows support. That means you will be able to install.

If packagist says something different than wiki, help page or website then this is the final answer.

That's not to say you won't encounter issues. But it will install.

2
  • Thank you v much have you any experience running 2.3.2 with PHP 7.1.30? ran into any problems?
    – jt9489
    Aug 5 '19 at 20:27
  • Not worked on anything higher than 2.3.1 just yet for any length of time with any number of extensions installed. So far any compatibility issues I've experienced have been the result of using extensions or the bundled extensions that come with M2. I use 2.3.2 docker instances to test extensions but that's about it. Not a true test. Aug 5 '19 at 21:00
0

No, Magento 2.3.2 does not work fine with PHP 7.1.x

Everything seems working fine until you start using your website. You'll find related php version bugs everywhere in the end.

Also, in official dev docs you'll find system requirements for Magento 2.3 :

Supported PHP versions:

~7.2.0

~7.3.0

https://devdocs.magento.com/guides/v2.3/install-gde/system-requirements-tech.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.