0

Centos 6 Apache 2.4

PHP 7.2

I am trying to complete the upgrade of the Magento 2.2.2 store to Magento 2.3 following this tutorial

https://digitalstartup.co.uk/t/how-to-upgrade-from-magento-2-2-8-to-2-3-1/528

However, I am getting the following error in CLI and Frontend and Admin at step 4.5 running

bin/magento setup:upgrade

[Exception] Warning: Use of undefined constant MCRYPT_BLOWFISH - assumed 'MCRYPT_BLOWFISH' (this will throw an Error i n a future version of PHP) in /home/redjohnco/public_html/vendor/magento/framework/Encryption/Encryptor.ph p on line 397

I am checking a lot of post since last 2 days online and see that in PHP7 7.2 mcrypt has been removed -

However, it seems Magento 2.3 or (my upgrade seems to need it)

I have a lot of posts on this and they mention it can be installed on PHP 7.2 However the instructions don't seem to work on my Linux Centos 6

all the packages mentioned in the posts whenever I run give output

No package libc-dev available.

No package pkg-config available.

No package mcrypt-1.0.1 available.

It seems it can't find the package or whatever it needs to install mcrypt for PHP 7.2

Please note I am using multiple versions of PHP on my server but when I'm checking in CLI SSH php-v I can see the version 7.2 is being used -

I switch using MultiPHP Manager

Also, I am using WHM CPANEL on the server

I have tried using this too

https://lukasmestan.com/install-mcrypt-extension-in-php7-2/

and similar other tutorials

The problem I get is when I try and run this command

sudo pecl install mcrypt-1.0.1

I keep getting

-bash: pecl: command not found

Please can anyone advise how I can fix this on centos 6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.