1

I just upgraded from Magento2.2.5 to 2.3.2 and now when I try to go to the site I get a bunch of errors written to the exceptions log file about modules versions being incorrect. For example

MSP_TwoFactorAuth data: current version - none, required version - 3.1.0

However when I look in the setup_module mysql table there is no row entry for the module MSP_TwoFactorAuth and when I run

php bin/magento setup:upgrade

It doesn't create the needed database row entry.

1

It looks like this module moved to magento official repo (Member of MSP Security Suite) and now name is different. So You can remove old module.

New one:

msp_twofactorauth

Please read:

https://github.com/magespecialist/m2-MSP_TwoFactorAuth - there is a note here

and this is official repo now:

https://github.com/magento/magespecialist_TwoFactorAuth

|improve this answer|||||
  • so how do I get magento to not look for MSP_TwoFactorAuth I know to get the new named module i could probably do composer require magespecialist_TwoFactorAuth but that wont help with the original error i am getting? – Jayreis Jul 31 '19 at 20:44
  • Disable module, remove old directory MSP (do backup before) and run composer require msp/twofactorauth I actually see on my database MSP_TwoFactorAuth 2.2.0 but its Magento 2.3.1. I ithink You have some conflict anyway, Can You paste exception log. – BartZalas Jul 31 '19 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.