0

I want to upgrade the Magento cloud version from 2.2.4 to 2.3.1. We cloned a branch to the local environment and then upgraded the site. Running the site in the local and it's confirmed that the version is upgraded to 2.3.1. We moved the required files from GitHub to the cloud rebuild branch. The version of the file is 2.3.1 but we are getting an error that DB is not upgraded.

"{"0":"Please upgrade your database: Run \"bin/magento setup:upgrade\" from the Magento root directory.\n"

As we cannot run setup upgrade, not sure how to resolve this issue. Can anyone help us with this?

  • can you run: "composer update" command? – Jimit Bhavsar Jul 31 at 10:38
0

You can run php bin/magento setup:upgrade command by connecting SSH

  • you can push again with sample commit , like you can add some comments on any file, and push changes to cloud. – balu Jul 31 at 13:13
0

The proper way to do this would be to update the version of the metapackage in your composer.json, run a composer update locally and then git push the updated lock and json.

  1. composer update "magento/magento-cloud-metapackage":">=2.3.1 < 2.3.2"
  2. git add composer.lock composer.json
  3. git commit -m "Upgrading to Magento 2.3.1"
  4. git push

ECE-Tools runs setup:upgrade during the deploy phase which will upgrade your database appropriately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.