0

I have a Magento Cloud server. In which I need to disable a Module. From my local environment, I have changed the app/etc/config.php "My_Module" => 0.

And committed the changes. But my changes not moved to the cloud server.

Can anyone help me with this?

  • What versions of ece-tools and Magento do you use? – BaDos Jul 29 '19 at 14:07
  • Try to run the module status command to check either your module exists if not then try with the upgrade and run compile too then check. – Mahmood Rehman Jul 30 '19 at 3:54
  • It might be your changes not affected in cloud server ka...Try yo pull your code and check whether your code if affected ... – Ranganathan Jul 30 '19 at 4:15
1

I would recommend running the php bin/magento module:disable command in a local checkout of your code to ensure that the proper module name is used as it is possible it is not matching approrpiately. This will add the MyCompany_MyModule => 0 to the config.php. After that, git add/commit the updated config.php and it should be disabled!

0

Try to disable using command line
command :- php bin/magento module:disable My_Module

  • Tried the same in local environment. We can't run this comment in Cloud server. – Shajitha Banu Jul 29 '19 at 13:14
0

The issue due to Disk Space not enough to run the deploy on Cloud Server. Hence we couldn't disable the module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.