0

I have a Magento store in 2.2.9, clients need this version to work with some module, at this moment when I access to the categories admin grid I get this error

Fatal error: Uncaught TypeError: Argument 2 passed to Magento\Framework\View\Element\UiComponentFactory::argumentsResolver() must be of the type array, null given, called in /var/www/html/vendor/magento/framework/View/Element/UiComponentFactory.php on line 220 and defined in /var/www/html/vendor/magento/framework/View/Element/UiComponentFactory.php:172 Stack trace: #0 /var/www/html/vendor/magento/framework/View/Element/UiComponentFactory.php(220): Magento\Framework\View\Element\UiComponentFactory->argumentsResolver('sw_ocat_categor...', NULL) #1 /var/www/html/vendor/magento/module-ui/Component/Form/Field.php(84): Magento\Framework\View\Element\UiComponentFactory->create('sw_ocat_categor...', 'imageUploader', Array) #2 /var/www/html/vendor/magento/framework/View/Layout/Generator/UiComponent.php(159): Magento\Ui\Component\Form\Field->prepare() #3 /var/www/html/vendor/magento/framework/View/Layout/Generator/UiComponent.php(156): Magento\Framework\View\Layout\Generator\UiComponent->prepareComponent(Object(Magento\Ui\Component in /var/www/html/vendor/magento/framework/View/Element/UiComponentFactory.php on line 172

And I can't see the grid, any ideas what is waiting for the argument?

  • have you tried reindexing ? – Mohit Rane Jul 27 at 5:13
  • yes, fixed by re installing and copied the backup, so, not sure whats was the problem... – lucasvm1980 Jul 30 at 14:19
  • you can add this to the answer. – Mohit Rane Jul 31 at 4:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.