1

After clicking insert/edit embedded media in the editor (wysiwyg) in magento admin, appears an error in my console. Indeed I can upload a video, but I can't insert it to my page. it says :

Uncaught TypeError: Cannot read property 'params' of undefined

editor_plugin_src.js

enter image description here

FYI im using magento 2.2.9 upgraded from 2.1.7, in nginx environment, and im using pub directory for docroot following this article https://support.hypernode.com/knowledgebase/installing-magento-2-on-hypernode/

Does anyone have any idea? Thanks in Advance.

  • have you tried inserting outside of the wysiwyg <video id="myVideo" width="100%" height="300px" autoplay="autoplay" muted="" loop="loop"> <source src="{{view url="/pub/media/movies/movie.mp4"}}" type="video/mp4" /> </video> – Dominic Xigen Jul 25 '19 at 12:31
  • hi dominic, thank you for your response. yes Ive tried to insert that directly without wysiwyg. however the error still appearing when we open / edit page in magento admin like this link . more over, we cant just insert html code for our client, he cant do that. do you have any suggestion? – EshaRamady Jul 25 '19 at 12:51
  • Does seem to be more an issue with wysiwy. You could try updating the wysiwyg github.com/pavelleonidov/magento2-tinymce4 Try on dev site first. Beyond that I don't know sorry. – Dominic Xigen Jul 25 '19 at 12:54
  • it works, thank you! I just think to update tinymce before, but not sure which module it is. you saved my day! – EshaRamady Jul 25 '19 at 13:11
0

I'll put as answer.

Does seem to be more an issue with wysiwyg.

You could try updating the wysiwyg http://github.com/pavelleonidov/magento2-tinymce4

Try on dev site first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.