0
Fatal error: Uncaught Error: Cannot instantiate interface Magento\Framework\Cache\FrontendInterface in /home/chicpla1/public_html/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php:50
Stack trace:
#0 /home/chicpla1/public_html/vendor/magento/framework/ObjectManager/ObjectManager.php(70): Magento\Framework\ObjectManager\Factory\Dynamic\Developer->create('Magento\\Framewo...')
#1 /home/chicpla1/public_html/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(160): Magento\Framework\ObjectManager\ObjectManager->get('Magento\\Framewo...')
#2 /home/chicpla1/public_html/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php(246): Magento\Framework\ObjectManager\Factory\AbstractFactory->resolveArgument(Array, 'Magento\\Framewo...', NULL, 'cache', 'Magento\\Framewo...')
#3 /home/chicpla1/public_html/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php(34): Magento\Framework\ObjectManager\Factory\AbstractFactory->resolveArgumentsInRuntime('Magento\\Framewo...', Array, Arr in /home/chicpla1/public_html/vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php on line 50
0

If you use redis, run:

redis-cli flushall

or you'll need to run the following commands:

  • Clear generated
  • Clear var/cache
  • Enable Magento modules: php bin/magento module:enable --all
  • Run these commands

php -dmemory_limit=1G bin/magento setup:upgrade

php -dmemory_limit=1G bin/magento setup:di:compile

php -dmemory_limit=1G bin/magento setup:static-content:deploy -f

php bin/magento cache:clean

php bin/magento cache:flush

I hope this will help

|improve this answer|||||
  • but not commad found error all php command error – KANZARIYA ANIL Jul 25 '19 at 5:58
  • Have you cleared the cache and generated folder before running the command php bin/magento module:enable --all. Secondly you only run this command redis-cli flushall if you have redis setup and running – Muhammad Hasham Jul 25 '19 at 6:02
  • but generate same error – KANZARIYA ANIL Jul 25 '19 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.