0

I am trying to install the module B2B module in my commerce Magento project. However, I am getting the below error.

Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for magento/module-checkout == 100.2.5.0 -> satisfiable by magento/module-checkout[100.2.5].
    • magento/extension-b2b 1.1.2 requires magento/module-checkout-address-search-negotiable-quote 100.1.0 -> satisfiable by magento/module-checkout-address-search-negotiable-quote[100.1.0].
    • magento/module-checkout-address-search-negotiable-quote 100.1.0 requires magento/module-checkout 100.3.2 -> satisfiable by magento/module-checkout[100.3.2].
    • Conclusion: don't install magento/module-checkout 100.3.2
    • magento/extension-b2b 1.1.1 requires magento/module-shared-catalog 100.1.1 -> satisfiable by magento/module-shared-catalog[100.1.1].
    • magento/module-shared-catalog 100.1.1 requires magento/module-user 101.1.1 -> satisfiable by magento/module-user[101.1.1].
    • Conclusion: don't install magento/module-user 101.1.1
    • Can only install one of: magento/module-user[101.1.0, 101.0.3].
    • Can only install one of: magento/module-user[101.1.0, 101.0.3].
    • Can only install one of: magento/module-user[101.0.3, 101.1.0].
    • magento/module-shared-catalog 100.1.0 requires magento/module-user 101.1.0 -> satisfiable by magento/module-user[101.1.0].
    • magento/extension-b2b 1.1.0 requires magento/module-shared-catalog 100.1.0 -> satisfiable by magento/module-shared-catalog[100.1.0].
    • Installation request for magento/extension-b2b ^1.1 -> satisfiable by magento/extension-b2b[1.1.0, 1.1.1, 1.1.2].
    • Installation request for magento/module-user == 101.0.3.0 -> satisfiable by magento/module-user[101.0.3].

Installation failed, reverting ./composer.json to its original content.

Can anyone have an idea about this issue?

Thanks in advance

2
  • You're probably trying to use the wrong version. You should just be able to composer install magento/extension-b2b and just let Composer deal with the dependencies. Jul 23 '19 at 13:53
  • If i tried that,i am getting below error composer install magento/extension-b2b Invalid argument magento/extension-b2b=^1.1. Use "composer require magento/extension-b2b=^1.1" instead to add packages to your composer.json.
    – S.Venky
    Jul 23 '19 at 14:16
0

It seems like you're having issues with dependencies, running these commands might solve it.

composer require magento/extension-b2b
bin/magento setup:upgrade
bin/magento setup:di:compile
bin/magento setup:static-content:deploy -f
bin/magento cache:clean

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.