0

We have a magento 2.2.5 based website and just tried installing the Amazon Sales Channel module (https://marketplace.magento.com/magento-module-amazon.html) however after installing it and running the Magento upgrade, compile and deploy command when we then go to login to our Magento admin and are presented with the below error.

I don't understand why I would have to downgrade our other Amazon modules in order to use this nor do I want to downgrade because I am concerned it will cause issues with other stuff on the site if I do.

Has anyone had this issue and if so any work around to getting it to work?

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Please 
upgrade your database: Run "bin/magento setup:upgrade" from the Magento root directory.
The following modules are outdated:
Amazon_Core schema: current version - 2.2.10, required version - 2.2.7
Amazon_Core data: current version - 2.2.10, required version - 2.2.7
Amazon_Login schema: current version - 2.2.10, required version - 2.2.7
Amazon_Login data: current version - 2.2.10, required version - 2.2.7
Amazon_Payment schema: current version - 2.2.10, required version - 2.2.7
Amazon_Payment data: current version - 2.2.10, required version - 2.2.7
| improve this question | | | | |
0

Please see this thread it may help: https://github.com/magento/magento2/issues/18248

| improve this answer | | | | |
  • That post is slightly different because the person has an older version of the Amazon modules and the error they are getting says they need a newer version. I have the opposite. My existing Amazon modules are newer and what the Amazon Seller Channel module seems to require according to the error message. – Jayreis Jul 23 '19 at 1:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.