6

Facing issue when running the command php bin/magento setup:upgrade

 The XML in file "D:/wamp64/www/porto/vendor/magento/module-inventory-catalog/etc/communication.xml" is invalid:
Element 'topic', attribute 'is_synchronous': The attribute 'is_synchronous' is not allowed.
Line: 9

Element 'topic', attribute 'is_synchronous': The attribute 'is_synchronous' is not allowed.
Line: 12

Element 'topic', attribute 'is_synchronous': The attribute 'is_synchronous' is not allowed.
Line: 15

Verify the XML and try again.
7
  • did you changed any thing in core files?
    – sudo55
    Commented Jul 22, 2019 at 9:23
  • no i just run command : composer update and after that i am facing that issue Commented Jul 22, 2019 at 10:06
  • I'm facing the same issue. Let me know if you found something.
    – Guerra
    Commented Jul 22, 2019 at 21:05
  • For some reason our file is out of date. Check this out raw.githubusercontent.com/magento/magento2/2.3/lib/internal/… is_synchronous is there. And isn't on mine.
    – Guerra
    Commented Jul 22, 2019 at 21:24
  • What is the final solution? I am also facing the same error. Commented Sep 12, 2019 at 15:04

3 Answers 3

0

I ended up disabling these two modules, then setup:upgrade would get past the error. bin/magento module:disable Magento_Amqp Magento_MysqlMq

0

This Issue is Genuinly Due to Unknown Tag in Your

D:/wamp64/www/porto/vendor/magento/module-inventory-catalog/etc/communication.xml

compare your file with

D:/wamp64/www/porto/lib/internal/Magento/Framework/Communication/etc/communication.xsd

is_synchronous attribute is used correctly or not

0

If you're running a multiple PHP version, It could be the cause,

In this case, should check the CLI and Server version, these should be the same

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.