0

Now the magento version is 2.2.6 target version is 2.3.1 :

steps we have followed to upgrade :

http://magefoo.com/upgrade-magento-from-2.2.6-to-2.3.0/

In the 8th step i.e 'composer update' the error happens :

Current PHP version is 7.0.3 while using this version no error but composer hangs at updating dependencies

I updated the PHP version to 7.1.9 then at composer update step the error happens is :

Problem 1
 - The requested package friendsofphp/php-cs-fixer (locked at v2.2.20, required as ~2.10.0) is satisfiable by friendsofphp/php-cs-fixer[v2.2.20] but these conflict with your requirements or minimum-stability.
Problem 2
 - The requested package sebastian/phpcpd (locked at 2.0.4, required as ~3.0.0) is satisfiable by sebastian/phpcpd[2.0.4] but these conflict with your requirements or minimum-stability.
Problem 3
 - magento/framework 100.0.20 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.19 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.18 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.17 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.16 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.15 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.14 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.13 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
  - magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
 - magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.1.30) does not satisfy that requirement.
 - php-cuong/magento2-regions-manager 2.2.1 requires magento/framework 100.0.*|100.1.*|101.0.* -> satisfiable by magento/framework[101.0.6, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.1.9, 100.0.18, 101.0.0, 100.0.19, 101.0.1, 100.1.10, 100.1.11, 101.0.2, 100.0.20, 100.1.12, 101.0.3, 100.1.13, 101.0.4, 101.0.5, 100.1.14, 100.1.15, 100.1.16, 101.0.7, 100.1.17, 101.0.8, 100.1.18, 101.0.9].
  - php-cuong/magento2-regions-manager 2.2.1 requires magento/framework 100.0.*|100.1.*|101.0.* -> satisfiable by magento/framework[101.0.6, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.1.9, 100.0.18, 101.0.0, 100.0.19, 101.0.1, 100.1.10, 100.1.11, 101.0.2, 100.0.20, 100.1.12, 101.0.3, 100.1.13, 101.0.4, 101.0.5, 100.1.14, 100.1.15, 100.1.16, 101.0.7, 100.1.17, 101.0.8, 100.1.18, 101.0.9].
   - php-cuong/magento2-regions-manager 2.2.1 requires magento/framework 100.0.*|100.1.*|101.0.* -> satisfiable by magento/framework[101.0.6, 100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.1.9, 100.0.18, 101.0.0, 100.0.19, 101.0.1, 100.1.10, 100.1.11, 101.0.2, 100.0.20, 100.1.12, 101.0.3, 100.1.13, 101.0.4, 101.0.5, 100.1.14, 100.1.15, 100.1.16, 101.0.7, 100.1.17, 101.0.8, 100.1.18, 101.0.9].
  - Can only install one of: magento/framework[102.0.1, 101.0.6].
 - Can only install one of: magento/framework[102.0.1, 101.0.0].
 - Can only install one of: magento/framework[102.0.1, 101.0.1].
 - Can only install one of: magento/framework[102.0.1, 101.0.2].
 - Can only install one of: magento/framework[102.0.1, 101.0.3].
 - Can only install one of: magento/framework[102.0.1, 101.0.4].
 - Can only install one of: magento/framework[102.0.1, 101.0.5].
 - Can only install one of: magento/framework[102.0.1, 101.0.6].
 - Can only install one of: magento/framework[102.0.1, 101.0.7].
 - Can only install one of: magento/framework[101.0.8, 102.0.1].
 - Can only install one of: magento/framework[101.0.9, 102.0.1].
 - Can only install one of: magento/framework[101.0.6, 102.0.1].
 - Can only install one of: magento/framework[102.0.1, 100.1.16].
 - Can only install one of: magento/framework[102.0.1, 100.1.17].
 - Can only install one of: magento/framework[100.1.18, 102.0.1].
 - magento/product-community-edition 2.3.1 requires magento/framework 102.0.1 -> satisfiable by magento/framework[102.0.1].
 - Installation request for magento/product-community-edition 2.3.1 -> satisfiable by magento/product-community-edition[2.3.1].
 - Installation request for php-cuong/magento2-regions-manager (locked at 2.2.1, required as *) -> satisfiable by php-cuong/magento2-regions-manager[2.2.1].

After that I tried

   composer update --lock

then the errors is

enter image description here

How should i solve this issues and upgrade my magento version(2.2.6) to the version 2.3.1 ?? Please do respond if anyone knows the solution. Thanks.

0

Your composer.json file should look a bit like this

https://github.com/DominicWatts/magento2-mirror/blob/2.3.1/composer.json

"require": {
        "magento/product-community-edition": "2.3.1"
    },
    "require-dev": {
        "friendsofphp/php-cs-fixer": "~2.13.0",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento2-functional-testing-framework": "~2.3.13",
        "pdepend/pdepend": "2.5.2",
        "phpmd/phpmd": "@stable",
        "phpunit/phpunit": "~6.5.0",
        "sebastian/phpcpd": "~3.0.0",
        "squizlabs/php_codesniffer": "3.3.1",
        "allure-framework/allure-phpunit": "~1.2.0"
    },
    "conflict": {
        "gene/bluefoot": "*"
    },

Run composer install

Can always use the --no-dev param to skip the dev requires

|improve this answer|||||
  • Thanks for the suggestion,But its still Not Working Same Error Happening again... – Hakeem P A Jul 18 '19 at 7:40
  • @HakeemPA just for the sake of getting it down have you tried using the --ignore-platform-reqs param. Obviously do this on a test site first. – Dominic Xigen Jul 18 '19 at 11:14
  • Not working...Same Error Happening again... – Hakeem P A Jul 20 '19 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.