1

Right now we are working on updating magento to latest version of magento 2.3.2 right now we are runing 2.2.7.

I following the guide for 2.3 branch found at https://devdocs.magento.com/guides/v2.3/cloud/project/project-upgrade.html

I have taken following steps :

Step1: Update ece-tools version

On local workstation, perform an update using Composer

composer update magento/ece-tools

Add, commit, and push code changes.

git add -A && git commit -m “Update magento/ece-tools” && git push origin

Step2: Back up the database

Create a local backup of the remote database.

magento-cloud db:dump

when i run this command in my terminal i get ‘magento-cloud’ is not recognized as an internal or external command, operable program or batch file.

Back up code and media.

php bin/magento setup:backup –code [–media]

To back up Staging or Production environment database before deploying

php vendor/bin/ece-tools db-dump

Step3: Complete the upgrade

I have PHP 7.1.30 version

Before completing the upgrade, update the autoload property I follow all the steps giving in https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html#update-autoload

set the upgrade version using

composer require magento/product-community-edition 2.3.2 –no-update

Then Update the project

composer update

After composer update i get some error

Your requirements could not be resolved to an installable set of packages.

Problem 1

- magento/magento-cloud-metapackage 2.2.7 requires magento/product-enterprise-edition 2.2.7 -> satisfiable by magento/product-enterprise-edition[2.2.7] but these conflict with your requirements or minimum-stability.

- magento/magento-cloud-metapackage 2.2.7 requires magento/product-enterprise-edition 2.2.7 -> satisfiable by magento/product-enterprise-edition[2.2.7] but these conflict with your requirements or minimum-stability.

- Installation request for magento/magento-cloud-metapackage >=2.2.7 <2.2.8 -> satisfiable by magento/magento-cloud-metapackage[2.2.7].

Can you please guide me how can i solve this issue..

Thanks in advance.

My composer.json is

{
"name": "magento/project-enterprise-edition",
"description": "eCommerce Platform for Growth (Enterprise Edition)",
"type": "project",
"version": "2.3.2",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"repositories": {
    "repo": {
        "type": "composer",
        "url": "https://repo.magento.com"
    },
    "amasty": {
        "type": "composer",
        "url": "https://composer.amasty.com/enterprise/"
    }
},
"require": {
    "magento/magento-cloud-metapackage": ">=2.2.7 <2.2.8",
    "gene/bluefoot": "^1.0",
    "amasty/promo": "^2.2",
    "sashas/bug-from-email": "^2.0",
    "amasty/shopby": "^2.11",
    "amasty/label": "^1.10",
    "connectpos/rest-api": "^1.1",
    "magento/product-community-edition": "2.3.2",
    "magento/product-enterprise-edition": "2.3.2"
},
"config": {
    "use-include-path": true
},
"autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/",
        "Zend\\Mvc\\Controller\\": "setup/src/Zend/Mvc/Controller/"
    },
    "psr-0": {
        "": [
            "app/code/",
            "generated/code/"
        ]
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ],
    "exclude-from-classmap": [
        "**/dev/**",
        "**/update/**",
        "**/Test/**"
    ]
},
"autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
},
"minimum-stability": "alpha",
"prefer-stable": true,
"extra": {
    "magento-force": true,
    "magento-deploystrategy": "copy"
},
"require-dev": {
    "allure-framework/allure-phpunit": "~1.2.0",
    "friendsofphp/php-cs-fixer": "~2.13.0",
    "lusitanian/oauth": "~0.8.10",
    "magento/magento-coding-standard": "~1.0.0",
    "magento/magento2-functional-testing-framework": "~2.3.14",
    "pdepend/pdepend": "2.5.2",
    "phpunit/phpunit": "~6.5.0",
    "sebastian/phpcpd": "~3.0.0",
    "squizlabs/php_codesniffer": "3.3.1"
}}
  • What if you run composer require magento/product-enterprise-edition, it looks like you missing this package. And check do you have access for this user to magento-cloud – BartZalas Jul 13 at 8:21
  • Thanks @BartZalas I run "composer require magento/product-enterprise-edition" then i get some new errors in my terminal like Problem 1 - The requested package magento/product-community-edition (locked at 2.2.7, required as 2.3.2) is satisfiable by magento/product-community-edition[2.2.7] but these conflict with your requirements or minimum-stability. Problem 2 - magento/magento-cloud-metapackage 2.2.7 requires magento/product-enterprise-edition 2.2.7 -> satisfiable by magento/product-enterprise-edition[2.2.7] but these conflict with your requirements or minimum-stability. – user9538602 Jul 13 at 9:25
  • other errors is Problem 2 - magento/magento-cloud-metapackage 2.2.7 requires magento/product-enterprise-edition 2.2.7 -> satisfiable by magento/product-enterprise-edition[2.2.7] but these conflict with your requirements or minimum-stability. - Installation request for magento/magento-cloud-metapackage >=2.2.7 <2.2.8 -> satisfiable by magento/magento-cloud-metapackage[2.2.7]. Installation failed, reverting ./composer.json to its original content. – user9538602 Jul 13 at 9:32
  • With that please read composer docs first. You can remove package and install needed version. or remove composer.lock and run composer install. magento.stackexchange.com/questions/247536/… – BartZalas Jul 13 at 9:55
  • Thank you @BartZalas i remove composer.lock from root directory and run composer install then i face same error that i mention in my question above.. – user9538602 Jul 13 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.