1

my WYSIWYG editor is not displayed in product description in the admin panel.

my sittings: Catalog-->magnage attributes--> description --> Enable WYSIWYG = "yes" system --> configuration --> Content Management --> Enable WYSIWYG Editor = "Enabled by Default"

has anyone any idea?

  • Do you get any js errors? – Marius Apr 5 '13 at 10:33
  • Does it mean you don't get WYSIWYG Editor button under description textarea? – user487772 Apr 5 '13 at 10:53
  • nope :(, and also nothing in the log files – Beloool Apr 5 '13 at 10:54
  • ya Tim, i dont get WYSIWYG Editor button under description textarea – Beloool Apr 5 '13 at 10:55
  • 1
    Did you find a solution? Share it with us! – Fabian Blechschmidt May 9 '13 at 14:06
2

General

First, confirm that the areas shows anywhere. Regardless, this error is occurring due to an issue in one of two areas:

  1. Incorrect/missing/superseded files
  2. Incorrect/missing configuration

1. Incorrect/missing/superseded files

Diff a known-good copy of your version of Magento against yours. Correct any differences, restore files, and reset theme settings such that the "default" behavior should be in effect

2. Incorrect/missing configuration

You've confirmed that the configuration settings to display this button are set, but Mage_Adminhtml_Block_Catalog_Helper_Form_Wysiwyg::getIsWysiwygEnabled() checks if the Mage_Cms module is active to display even the disabled version of the button. Check that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.