1

We have a multilanguage store, was working fine. Now we changed the URL for every language but now the switch is not working anymore. Not even changing the language anymore.

compile, cleaning cache, even setting to production is not working.

www.koperenpannen.com / www.copperpans.store

  • Please describe the steps in your question, what you have done so far. – Mohit Kumar Arora Jul 11 at 5:25
  • Created a store - 3 languages, that worked in www.koperenpannen.com languages etc worked everywhere. Then we changed the url for the english and german shop at base url. After that we did setup:upgrade, compile clean cache. That did not work (language switch keeps going back to the home page of the current language.) so set site in developer mode and then to production. Same result. – Peter Vis Jul 11 at 6:03
  • If I change manually (change the storeview code behind the url) it works. So it is something in the language/storeview switcher I think. But I can not find a resolution for it. – Peter Vis Jul 11 at 6:31
  • For URL change, you need to create 3 different stores (each having a single store view with a particular language). Only 1 store with 3 store view will not work in this case. – Mohit Kumar Arora Jul 11 at 6:33
  • Just a store with it own storeview ? But then I am losing my language switcher. So for every store I need 3 storeviews too ? Is weird. You should think it must be possible. It is only because of adding the url it is not working anymore. Or should I hardcode the language switcher to the url it has to go too ? – Peter Vis Jul 11 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.