0

We are attempting to upgrade from version 2.1.16 to 2.3.2 on CentOS7.

Previously we were running PHP 5.6.30. I uninstalled that version, installed version 7.2.20, and received the following errors when attempting the upgrade.

What is strange to me that using the upgrade utility in the admin pages is able to move past this check, however running it through the command line encounters these issues.

My question then is, am I missing a step here, or do I need to run multiple successive upgrades (eg. upgrade to PHP 7.0.0 -> upgrade to Magento 2.2 -> upgrade to PHP 7.1 -> upgrade Magento 2.3 -> upgrade to PHP 7.2)?

- magento/framework 100.1.18 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.17 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.16 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.2.0-rc20 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0-rc3 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0-rc2 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0-rc1 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.18 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.17 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.16 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.14 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.13 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.12 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.11 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.10 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.9 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.2.0-rc20 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0-rc3 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0-rc2 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.2.20) does not satisfy that requirement.
- magento/framework 100.1.0-rc1 requires php ~5.5.22|~5.6.0|~7.0.0 -> your PHP version (7.2.20) does not satisfy that requirement.
6
  • described what you did in order to upgrade. upgrade to 2.3.X is not that simple Commented Jul 10, 2019 at 13:14
  • @PhilippSander Followed the documentation as much as possible. Downloaded the new version, replaced my update folder with new one, updated the composer.json, uninstalled all PHP extensions, installed new ones, ran composer update. Commented Jul 10, 2019 at 13:18
  • "much as possible" what did you skip? Commented Jul 10, 2019 at 13:20
  • @PhilippSander php composer.phar install --no-dev -> php bin/magento setup:upgrade -> php bin/magento setup:di:compile -> composer require magento/product-enterprise-edition=2.3.2 --no-update -> composer create-project --repository=repo.magento.com magento/project-enterprise-edition=2.3.2 temp_dir --no-install -> rm -rf update -> mv temp_dir/update . -> rm -rf temp_dir -> composer update Commented Jul 10, 2019 at 13:25
  • but that's not all you have to do.... did you run the "pre_composer_update_2.3.php" ? Commented Jul 10, 2019 at 14:46

1 Answer 1

0

I finally discovered the issue. In the composer.json we had "magento/data-migration-tool": "2.1.3" leftover from the Magento 1 to 2 upgrade. Removing that fixed the issue.

2
  • Have you got any DB error while upgrade from 2.1.16 to 2.3.2 directly? I am also trying to upgrade magento and getting customer group id error Commented Jul 19, 2019 at 15:43
  • @Yogendra-eCommerceDeveloper had something similar. Resolution was just to add in the missing column. Commented Aug 21, 2019 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.