0

We have the problem when uploading product images into Magento 2 store.

When we upload the image is shown up into the backend but not in the frontend. There when you inspect the image you will get a 404 error.

If you take a look into the file path and check this on the server you will see that the folder is not there. Magento creates other folders where the images are in but not the one that needs to be there to show the images in the frontend.

File permissions are checked, owner rights are checked. Reindex, clear cache obv is done.

Someone ever had this problem?

EDIT:

I have contact the theme builders and they told me its a problem on the server side. The server doesn't support auto run function resize image for magento 2 they told me.

Anyone knows how to check or fix this?

  • deploy static content and clear cache – ASQ Jul 10 at 7:29
  • Did you check the path for the images in the backend as well as a frontend? After that remove the cache folder from pub/media/catalog/product/cache – Kamlesh Solanki Jul 10 at 8:09
  • Try this command: sudo php bin/magento catalog:image:resize then flush cache and try again. – mighty_hk Jul 10 at 8:23
  • Mighty_hk i found the problem i guess. the command catalog:image:resize works but i dont want to run the command every time i add new products to show the images. github.com/magento/magento2/issues/19710 i have found and more people has the same problem. Anyone knows how to fix the problem so i dont have to run the command every time? – Marlon van Leeuwaarde Jul 10 at 9:23
  • @mighty_hk is there a way to run the command php bin/magento catalog:image:resize as a cronjob? so it automaticly runs every 30 min for example? – Marlon van Leeuwaarde Jul 12 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.