0

Due to the newly created attribute(via program) of the type "weee", getting an error in reindexing.

Catalog Search indexer process unknown error:
SQLSTATE[42S22]: Column not found: 1054 Unknown column 'e.custom_attr_weee' in 'field list', query was: SELECT `e`.`entity_id`, `e`.`type_id`, `e`.`custom_attr_weee`, `e`.`sku` FROM `catalog_product_entity` AS `e`
 INNER JOIN `catalog_product_website` AS `website` ON website.product_id = e.entity_id AND website.website_id = 1
 INNER JOIN `catalog_product_entity_int` AS `visibility_default` ON visibility_default.entity_id= e.entity_id AND visibility_default.attribute_id = '99' AND visibility_default.store_id = 0
 LEFT JOIN `catalog_product_entity_int` AS `visibility_store` ON visibility_store.entity_id= e.entity_id AND visibility_store.attribute_id = '99' AND visibility_store.store_id = 1
 INNER JOIN `catalog_product_entity_int` AS `status_default` ON status_default.entity_id= e.entity_id AND status_default.attribute_id = '97' AND status_default.store_id = 0
 LEFT JOIN `catalog_product_entity_int` AS `status_store` ON status_store.entity_id= e.entity_id AND status_store.attribute_id = '97' AND status_store.store_id = 1 WHERE (IF(visibility_store.value_id > 0, visibility_store.value, visibility_default.value) IN (3, 2, 4)) AND (IF(status_store.value_id > 0, status_store.value, status_default.value) IN (1)) AND (e.entity_id > 0) AND (e.entity_id 

If we create this attribute via the admin panel, everything works fine. What might be the issue? Help me to resolve it.

0

When an attribute is created via admin panel or 3rd program, it must be stored in eav_attribute tablee. In your case, the program added weee attribute directly into catalog_product_entity table, it's forbidden and causes this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.