0

I have updated the Magento version to 2.3.2. After updating the Magento, the product images are not visible.

The product catalog images are coming from the old cache file directory.

I have done the following.

  1. Remove pub/media/catalog/product/cache . (Removing this folder frees up space.)
  2. Run bin/magento catalog:image:resize to generate a new image cache

Still, I'm facing the same issue.

  • Have you checked pub/media is having correct permissions? Check your browser console to see for the images and check for the images in pub folder – Raj Mohan R Jul 9 '19 at 7:50
  • Yeah. I have the images in pub folder with correct permission. – Rathna Jul 9 '19 at 7:53
  • So what response are you getting in network tab ? – Raj Mohan R Jul 9 '19 at 7:54
  • I'm not getting any errors on console tab. – Rathna Jul 9 '19 at 7:56
  • 1
    Goto your admin flush catalog images cache and CSS/Js Cache. Once cleaning it flush magento cache. It would solve your problem unless you are using any third party caches/PWA – Raj Mohan R Jul 9 '19 at 8:43
4

A common issue is that Magento is looking for the pictures in the old cache files that are missing after the upgrade as the cache was cleared.

Try below actions:

  1. A catalog reindex. Follow below article for reindex steps.

https://support.weltpixel.com/hc/en-us/articles/115000355673-How-to-reindex-your-Magento-2-store-from-admin-or-SSH-CLI

  1. Re-generate the image catalog by using the command below via CLI:

php bin/magento catalog:images:resize

I hope this will help, Once you done please update me

  • When i'm running this command - php bin/magento catalog:images:resize File '/var/www/html/proj/pub/media/catalog/product/b/u/button_image_1.jpg' does not exist. – Rathna Jul 9 '19 at 8:30
  • So, I have manually adding the missing images. Those images are deleted products. I dont know, why its showing error on removed product images. – Rathna Jul 9 '19 at 10:13
  • Becz,Deleted product images are still referenced in the following table. catalog_product_entity_media_gallery, catalog_product_entity_media_gallery_value, catalog_product_entity_media_gallery-value_to_entity. – Rathna Jul 11 '19 at 8:25
  • You can remove references to deleted images with te folowing query: DELETE FROM catalog_product_entity_media_gallery WHERE value_id IN ( SELECT cm.value_id FROM catalog_product_entity_media_gallery cm LEFT JOIN catalog_product_entity_media_gallery_value cmv ON cm.value_id = cmv.value_id WHERE cmv.value_id IS NULL) – Dennis van Schaik Jul 29 '19 at 10:48
  • @DennisvanSchaik MYSQL returns Table 'catalog_product_entity_media_gallery' is specified twice, both as a target for 'DELETE' and as a separate source for data – dawhoo Sep 18 '19 at 20:07
3

I had this exact same problem with Magento 2.3.2

For me it was product thumbnail images that had the wrong cache hash path and was showing the std Magento image placeholder.

I was using a custom theme.

No matter how many times i ran "php bin/magento catalog:images:resize" still the same problem. I found that the images were being generated using the Luma theme etc/view.xml instead of the custom theme etc/view.xml file.

The problem. When viewing my custom theme in the browser which uses different size images to Luma theme, Magento could not find the images and shows 404 error.

The fix.

  1. Replace Luma themes etc/view.xml with my custom theme etc/view.xml
  2. Using SHH run "php bin/magento catalog:images:resize

I took me a week to find out how to fix this, but it all work fine now.

  • "I found that the images were being generated using the Luma theme etc/view.xml " you saved me with this. Thank you :) – Vvvaida Nov 11 '19 at 8:52
2

I had faced similar issue and resolved it by running the following command:

php bin/magento sampledata:deploy
php bin/magento indexer:reindex
php bin/magento cache:flush

Although I was working with sample data, not sure about real data.

I hope it helpful for someone.

1

I have found the following article if you are using Magento Commerce

Cached images are not loaded after 2.2.X to 2.3.X upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.