0

The products after importing does not appear on Magento 2.3 on the front end. But after you click Edit and save without any modification it show,

0

Without more info I believe this is an indexing issue

You can do this via command line or admin with extension

https://github.com/magepal/magento2-reindex

Either way you need to get an index into your import workflow

0

You need reindex Magento store:

a - Reindex from Magento admin

  1. Go to System > Index Management and check indexers status
  2. Select the items that are marked as Reindex required and go to Actions > Update on schedule

This will trigger a reindex for selected indexers.

b - Reindex via SSH / CLI (recommended)

  1. Connect to your Magento 2 installation in the root of your project. (usually in public_html )
  2. Reindex all Magento 2 indexers using below command
php bin/magento indexer:reindex
  • hi the problem is not solved – Sami Naser Jul 15 at 15:10
  • 1: The products must be Visible in Catalog. 2: The products must be Enabled. 3: Product must have a stock Quantity. 4: The product must be set to In Stock. 5: If the product is set not to track stock, it still has to have a stock Quantity and be set to In Stock. 6: The product must be assigned to the target Category. 7: If using multi-website mode (or if you imported the products through Data Flow), the products must be assigned to the target Website. (check table catalog_product_website) 8: You must refresh your Cache / Indices, just to make sure.(php bin/magento cache:flush ) – Yeong Kim Jul 17 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.