0

Added below code into Ui component layout file but In enterprice version it is showing default page builder functionality not showing wyswig editor

<field name="content">
    <argument name="data" xsi:type="array">
        <item name="config" xsi:type="array">
            <item name="label" xsi:type="string" translate="true">Content</item>
            <item name="formElement" xsi:type="string">wysiwyg</item>
            <item name="source" xsi:type="string">post</item>
            <item name="sortOrder" xsi:type="number">70</item>
            <item name="wysiwyg" xsi:type="boolean">true</item>
            <item name="dataScope" xsi:type="string">content</item>
            <item name="additionalClasses" xsi:type="string">admin__field-wide</item>
            <item name="validation" xsi:type="array">
                <item name="required-entry" xsi:type="boolean">true</item>
            </item>
        </item>
    </argument>
</field>
0

You miss formElement attribute in field tag,take this as reference https://github.com/magento-devdocs/pagebuilder-examples/blob/master/Example/PageBuilderQuote/view/adminhtml/ui_component/pagebuilder_example_quote_form.xml

0

Page Builder is enabled for all WYSIWYG fields unless explicitly disabled. You can disable it per instance using the following code:

<argument name="data" xsi:type="array">
    <item name="config" xsi:type="array">
        <item name="wysiwygConfigData" xsi:type="array">
            <item name="is_pagebuilder_enabled" xsi:type="boolean">false</item>
        </item>
    </item>
</argument>

You can read more about this in our developer docs: https://devdocs.magento.com/page-builder/docs/reference/architecture.html#integration-with-magento-and-custom-modules

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.