0

After upgrading magento to 2.3.2 I can't see the Admin User Grid anymore. enter image description here System Log Shows This error

[2019-07-01 10:22:00] main.CRITICAL: Item (Magento\User\Model\User\Interceptor) with the same ID "4" already exists. [] []

I'm still quite new to Magento and have no idea what this ID refers to

I've checked the admin_user table in database and all seems to be fine. No duplicate IDs. I'm guessing it's some other table but I have no idea which. enter image description here Any help would be appreciated. Thank you.

  • Suggest to try with upgrade and compile command. – Anas Mansuri Jul 1 '19 at 14:32
  • i have tried setup:upgrade, setup:di:compile, indexer:reindex, setup:static-content:deploy and removing generated var and pub static folders... with no improvement – roman p. Jul 1 '19 at 14:39
  • Do you have any join with user table here? – Sohel Rana Jul 1 '19 at 16:14
  • Not that I'm aware of. I haven't been altering anything in magento code. And all the third party plugins worked fine in 2.3.1. I have no clue where to look for what's causing this. – roman p. Jul 2 '19 at 8:26
  • I've also just noticed it might be something else, a js error I'm getting this error in the console TypeError: $(...).down(...) is undefined in grid.js:427:66 It is the only page in admin panel that has this error – roman p. Jul 2 '19 at 22:14
0

In case anyone searches this

OK, appears that the issue was caused by a duplicate records in the authorization_role table

i have 7 admins and 3 integrations so i should have

3 integration roles 7 admin user roles and 1 admin role

instead i had

3 integration roles 9 admin user roles and 1 admin role

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.