0
  • I am upgrading Magento 2.3.1 Community Edition to Magento 2.3.1 Enterprise Edition.
  • All these prerequisites are done ✅
  • By Upgrade from the Magento Admin it do not give option of Eneterprise Edition in the list, it is only CE.
  • By following Command line Upgrade, it stucks when I execute:

    composer require magento/product-enterprise-edition=2.3.2 --no-update
    

    and prompts this error message:

[InvalidArgumentException]
Could not find a matching version of package magento/product-enterprise-edition. Check the package spelling, your version con straint and that the package is available in a stability which matches your minimum-stability (stable).

The issue is not getting solved by many developers like me. Need your kind attention !

  • 1
    do you have your correct credentials in your ~/.composer/auth.json ? – Philipp Sander Jul 1 at 13:38
  • 1
    have you tried change the composer.json manually and then running composer update? – Philipp Sander Jul 1 at 13:43
  • Yes, I tried by changing composer.json. This is how I edited it. Pls see to verify changes are correct or not. magento.stackexchange.com/questions/278139/… – Ajwad Syed Jul 1 at 14:47
  • you should never, EVER post your access keys public!!!! – Philipp Sander Jul 1 at 14:51
  • 1
    you shouldn't even do this – Philipp Sander Jul 1 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.