2

I have looked a lot but can't find the solution to this issue on my admin side

when I run php bin/magento setup:di:compile i get errors from 3rd party modules even these modules are off from config.php and also tried permission to genereted and var/di .........thanks in advance

EDIT I am using docker

enter image description here

3
  • Can you please post the error you are getting? Jul 1, 2019 at 11:19
  • updated my Question
    – Asad Ullah
    Jul 1, 2019 at 11:25
  • yes i have that
    – Asad Ullah
    Jul 1, 2019 at 11:42

3 Answers 3

1

If you are not using those 3rd party module, Kindly remove from the project Otherwise, whenever you run di:compile command, you get those error again

Remove Unused observer from events.xml

check controller constructor

17
  • tried this by removing 3rd party module but now getting error that file does not exit of that 3rd party module that i just removed
    – Asad Ullah
    Jul 1, 2019 at 11:24
  • Please disable module before remove from project Jul 1, 2019 at 11:25
  • already disabled from config.php
    – Asad Ullah
    Jul 1, 2019 at 11:26
  • Post error when you run bin/magento setup:di:compile Jul 1, 2019 at 11:27
  • nope didn't helped this solution Interceptors generation error while di:compile
    – Asad Ullah
    Jul 1, 2019 at 11:29
1

I have been looking for over two days for the solution. Here i found something that can help

1: make a fresh copy of the site to my local

2: change database credentials from app/etc/env.php

3: rename auth.json.sample to auth.json

4: provide new your magento keys from marketplace in auth.json file

5: run : php bin/magento setup:upgrade

If you get the error: Can't run this operation: deployment configuration is absent. Its mean you config.php file is missing from app/etc/ location, take following steps.

Either found an existing config.php and copy it to under desired location. OR Run the command php bin/magento module:enable --all

run : php bin/magento setup:upgrade

0

Try the below commands

find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} +

find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} +

sudo chown -R <Magento user>:<web server group> .

rm -rf var/di var/view_preprocessed var/cache var/page_cache pub/static/frontend generated/*

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy -f

Do run these commands with proper permission.

9
  • tried this but no luck
    – Asad Ullah
    Jul 1, 2019 at 11:41
  • So do you have the particular module TM_TrackingOrders still installed Jul 1, 2019 at 11:43
  • yes i have that
    – Asad Ullah
    Jul 1, 2019 at 11:43
  • the problem is when i clear this one file issue i get another file and then next and so on
    – Asad Ullah
    Jul 1, 2019 at 11:44
  • Can you share this file Controller/Adminhtml/Test/Index.php file of that module Jul 1, 2019 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.